クラッシュ解決。。

そういえばこの話、書いてなかったね。

いまそんなに「書きたい欲」があるわけじゃないけど、忘れないうちに書いておこう。同じことで悩んでる人がひとりでもこれを読んで、そうだったのか!と気づくように。

1か月くらい前にWindowsマシンを購入して。あたしはauのひかり5Gbpsに加入してるんだけど、いままではマシンのオンボードLANで1Gpbsしか出てなかった。それが悔しくて。で、1年くらい前にASUSの10Gbps対応のLANカード「XG-C100C」ってヤツを買ったんだけど、それがPCI Express x4対応で。前のマシンはx16がビデオカードで埋まってて、あとは全部x1のスロットしかなくて。うー、新しいLANカード、挿せないじゃん、と思ってた。

新しいPCを購入したのは、半分くらいはそれが理由かも。ネットで慎重に調べて、DELLのちょい高めのxps 8930ってヤツだったら、ちゃんとPCI Express x4のスロットがついてることを確認して購入した。

で、ASUSの10Gpbs対応LANカード「XG-C100C」をさっそく挿したら、下りが3Gbspとか出てさ。わお、と思った。まあ、実際にどのくらい実利があるのかは別の話なんだけど。笑

で、新しいマシンを使い始めてから、ずっと悩み続けたことがあり。それは、なんと、マシンを使ってると、いきなりブルースクリーンが現れて、そのまま再起動しちゃうのよ。ひどいときなんかは、マシンが起動した直後にブルースクリーンが現れてそのまま再起動なんてことも。

買ったばかりのマシンでブルースクリーンが頻発するなんて、いままで経験がなかったから、マシンを疑ってみたりして。そういえばこれ、一日でも早く手に入れたいから即納マシンをGetしたんだけど、即納ってことは初期不良で返ってきたヤツをリファービッシュして販売してるんじゃないか、とか。マザーボードかメモリーあたりに不具合があるんじゃないか、とか。

で、ずっと悩んで、時間があれば、ブルースクリーンの原因をネットでいろいろ検索してて。まあ、周辺機器が怪しい、ということに思い至って、最初に疑ったのが、ASUSのLANカード。

で、ASUSのサイトに行って、最新のドライバに更新しようとしたら、すでに最新のモノが使われてます、みたいな。たしか当たってるドライバはWindowsが自動的に見つけてきたヤツで。うーん、そうなのかー、と思って、当該製品のAmazonのレビューを見てたら、なんかドライバはASUSじゃなくてチップの開発元のAquantia(現Marvell)のサイトからAQC107用の最新のドライバを落としてくるといい、なんていう有益そうな情報が。

さっそく行ってみた。ドライバ、落としてみたんだけど、やっぱりWindowsが見つけてきたヤツが最適だよ、と言われて、入れ替えはされなかったような気が。

で、もっといろいろ調べてたら、ASUSのLANカードのチップの開発元Aquantia(現Marvell)が出してる、チップをファームアップするツールがあることを知った。

そんなのASUSのサイトにはなかったよ!と思いながらも、ツールを落として、新しいファームウェアをアレしてみた。

そうそう、ここのページの記述が全面的に参考になった。というか、ここのページを見つけなければ、ファームアップなんかできなかったよ。

Aquantiaのファームアップのツールは、自社製カードしか対応してないのよ。ASUSのヤツは継子扱いで対象外。それをなんとかファームアップのツールを騙して?ファームアップをしちゃおう、という話ですね。

もちろん、ファームアップは一定の危険を伴いますので、自己責任でお願いします。メーカー(ASUS)が認めてないツールを使ってLANカードが壊れたとしたら、保証の対象外になる可能性が高いです。

いまの時代、コマンドラインから使うツールって珍しいけどねえ。でも、やってみたら、あっさり上手くいきました!

それからは便秘も解消。じゃなくて、ブルースクリーンとは無縁の夫婦生活が♪ じゃなくて快適なWindows生活が。笑

うーん、なんかすっきり。やっぱり祈ると違うな。DELLのxps8930くん、疑ってゴメンね。さすがにいま売られてるASUS XG-C100Cはすでにファームアップされて無問題だと思いますが。あと、僕の環境で不具合が発生したというだけで、この不具合が別の環境(マザーボードとか、OSとか)で発生するとは限りませんもんね。

同じことをキュッとまとめてAmazonのレビューに書いてきます。

何度でも書くけど、半分は自己満足だけど、もう半分は、同じことで悩んでる人を、ひとりでも救えたらいいな、という素朴な気持ちから。ネットはお互い様で成り立ってるからね。

追記★
GoogleのSPEEDTESTをfirefoxでやってみたら、下りは3000Mbpsとかふつうに出るんだけど、上りが200Mbpsとかお話にならない遅さで。ちと待て。iPhone XS Maxでも、上りは500Mbpsとか出てるぞ、おいコラ。と思って、またいろいろ調べてみたら、デバイスドライバのプロパティの「詳細設定」でジャンボパケットの項目をdisableから9014Bytesにしろという日経なんちゃら様のありがたいご託宣が。auのルーターBL1000HWにも同じ設定を見つけてONにした。んだけど、上りの遅さは変わらず。ブラウザをマイクロソフトのEdgeに替えてみたら、少しは速くなるんだけど、あんまり改善せず。

うーん、やっぱ安物のLANカードはダメってことなのかな。LANカードで13,000円くらいしたから、けっこういい値段だと思ったんだけどねぇ。かなすぃねぇ。。笑

たしかに他の10Gbps対応LANカードを見ると、ふつうに3万とかしてて。けどLANカードごときに3万も出さないよねぇ。企業ユーザーじゃあるまいし。撮影データのアップロードだって、せいぜいDVD何枚か分、数ギガバイトなわけで、上りがそんなに速くなくちゃいけないという必要性は、まったくないんだよな。単なるスペックオタク、数の話なので、まあ大人になりますかね。

まあけど、マシンがクラッシュしなくなったのは本当にありがたい。っていうか、そんなの当然とも言えるけど。でも、まあ、これだけ快適に仕事をさせてもらえてるんだから、感謝しなきゃね。自分の周りのすべてのモノに深く感謝しなきゃ。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください